Issue with Direct Debit Mandate Creation

Incident Report for Acquired.com

Resolved

The issue is now fully resolved and our platform is stable and operating as normal.

Thank you for your patience and we apologise for the inconvenience caused to your business.
Posted Jul 22, 2025 - 09:35 BST

Identified

We’re currently unable to create new direct debit mandates due to an issue with an upstream provider. Investigation is ongoing and we’ll share updates as soon as we have more information.
Posted Jul 21, 2025 - 13:02 BST
This incident affected: Hub.